Identity Data, Documents & Biometrics

Below you'll find status information for GBG Identity Data, Documents & Biometrics.

Service Incident for - AcuFill WebService - AcuFill Service - EU

Incident Report for GBG Identity

Resolved

The service has been restored and is operating normally. We identified degraded availability affecting the EU AcuFill service and implemented corrective actions to restore service stability. We will continue to monitor the service and perform a root cause review to prevent recurrence.

Incident Start Time: 31/07/2026 11:22 EST

Incident Resolution Time: 31/07/2026 14:29
Posted Jul 31, 2026 - 19:56 BST

Investigating

We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your business and we’re working hard to get this back up and running.
Posted Jul 31, 2026 - 19:18 BST
This incident affected: AcuFill WebService (AcuFill Service - EU).