Identity Data, Documents & Biometrics

Below you'll find status information for GBG Identity Data, Documents & Biometrics.

Update: Kleber Partial Outage

Incident Report for GBG Identity

Resolved

The issue affecting some Kleber Production instances has been resolved.

To prevent similar issues, we are currently upgrading the storage and instance sizes across all Kleber Production clusters.

All services are operating normally. Thank you for your patience and understanding.
Posted Jul 29, 2026 - 06:01 BST

Investigating

We're currently investigating a partial outage affecting some Kleber instances caused by disk space exhaustion. Our team is working to identify the root cause and restore full service. We'll provide further updates as they become available.
Posted Jul 29, 2026 - 05:23 BST
This incident affected: DataTools (Kleber, CA+).