We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.
Posted Jul 30, 2026 - 08:36 BST
Update
The match rate for this item check is steadily increasing and we believe the issue has now been resolved. Our teams are closely monitoring this before closing the incident.
Posted Jul 29, 2026 - 20:00 BST
Update
We're continuing to experience a service disruption which may cause checks for China national ID to result in a 'No match' . We're sorry for the impact this may be having on your business. We're working hard to restore service.
Posted Jul 29, 2026 - 17:05 BST
Update
We're continuing to experience a service disruption which may cause checks for China national ID to result in a 'No match' . We're sorry for the impact this may be having on your business. We're working hard to restore service.
Posted Jul 29, 2026 - 14:07 BST
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Jul 29, 2026 - 10:46 BST
This incident affected: GBG ID3global (China National ID (0361)).