Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 03, 2026 - 00:00 BST
Scheduled
Dear GBG Detected User
Please see the details of Release 9.6, scheduled for Thursday, 3rd September.
New Features:
Shareholder Entities A new module to collect information about direct and indirect shareholders that are legal entities. Collect the ownership tree above a specified percentage directly from the client and automatically screen declared entities. Key Features:
• Set the declaration requirements - Set the minimum percentage for your customer to declare through the ownership structure • Works like people modules - Choose what data is to be declared through the data model • Convert from data source - If the data is available in the jurisdiction then user can convert from data source in Portal and Case Management
Key Benefits: • Collect ownership structure information directly from the customer • Screen the entities on profile submission
API Client Creation Changes to the Integration Information page in Case Management enable direct API client management.
Key Features: • Self-Service Credential Management - Instantly generate, view, and revoke OAuth 2.0 client IDs and client secrets directly from your developer settings without submitting support tickets. • API Scopes - Assign precise permissions (e.g., read-only, write-access) to each credential to ensure strict adherence to the principle of least privilege.
Key Benefits: • Faster Time-to-Integration - Eliminates manual onboarding delays, allowing your engineering and partner teams to start building and testing custom integrations in minutes. • Enhanced Platform Security - Prevents credential sharing and minimises attack surfaces by ensuring external applications only hold the minimum permissions required.
Onboarding Portal UX and UI Enhancements Three clear areas of friction in the Onboarding Portal were identified and addressed as part of continual improvements across the platform.
Key Features: • Reduce duplicate Onboarding Entities - moving the "Onboard New Entity” action to a less prominent position. • Reduce misclicks in modules - greater visual prominence given to the primary actions. • Increase final submission rates - reposition “Submit” and add a persistent guidance panel to act as a central reference point
Key Benefits: • Streamlined submission workflow for end users completing onboarding profiles Improvements: • Representative Pre-fill - Representative workflows no longer pre-fill the Date of Birth field in the Onboarding Portal. • Corrected a typographical error in the Request More Information email template. • Updated profile form display logic in Case Management to ensure forms display strictly within the designated section for the profile.
Any questions, please contact GBG Detected Support.
Posted Aug 27, 2026 - 09:51 BST
This scheduled maintenance affected: GBG Detected (Detected Dashboard, Detected On-Boarding Portal, Detected API, Detected company processing).