Identity Data, Documents & Biometrics

Below you'll find status information for GBG Identity Data, Documents & Biometrics.

Service Incident for - GreenID - AU / NZ greenID Test Environment

Incident Report for GBG Identity

Resolved

The issue affecting MSSL certificate authentication in the GreenID AU/NZ 'Test' Environment has been resolved. Customers should now be able to access the service as expected. Thank you for your patience whilst we restored service.
Posted Jul 30, 2026 - 22:42 BST

Update

We are continuing to investigate this issue.
Posted Jul 30, 2026 - 11:54 BST

Update

We are continuing to investigate this issue.
Posted Jul 30, 2026 - 06:46 BST

Investigating

We are currently experiencing an issue impacting customers using MSSL certificates to access the TEST environment. Our team is investigating the issue and is working to resolve it as quickly as possible. We will provide further updates as more information becomes available.
Posted Jul 30, 2026 - 06:44 BST
This incident affected: GreenID (AU / NZ greenID Test Environment).